Access to Documents for Board Users

Incident Report for Carta System Status

Resolved

We've resolved the issue and all Board documents should be accessible once again.
Posted Sep 15, 2021 - 16:27 PDT

Investigating

Customers using our Board product may have problems accessing their documents. We are currently investigating.
Posted Sep 15, 2021 - 15:18 PDT
This incident affected: Application.