Fund administration products not loading

Incident Report for Carta System Status

Resolved

This incident has been resolved.
Posted Jul 12, 2023 - 09:15 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 12, 2023 - 08:30 PDT

Investigating

We are currently investigating our Fund Administration product not loading for some users.
Posted Jul 12, 2023 - 08:15 PDT