Email delivery to Microsoft hosted email addresses
Incident Report for Carta System Status
Resolved
We have returned to normal delivery rates to Microsoft Outlook hosted email addresses.
Posted May 10, 2021 - 09:03 PDT
Monitoring
Microsoft Outlook hosted email addresses can now successfully receive Carta emails. We are actively monitoring email deliverability to ensure stability for all Carta users.
Posted May 07, 2021 - 11:26 PDT
Investigating
We are aware of an ongoing issue where users with Microsoft Outlook hosted email addresses are unable to receive some emails from Carta. We’re actively working to resolve the issue and apologize for any inconvenience.
Posted May 05, 2021 - 15:27 PDT
This incident affected: Application.