Intermittent Page Issues

Incident Report for Carta System Status

Resolved

Upstream issues have been resolved, no further user issues are expected on Carta applications
Posted Nov 18, 2025 - 12:00 PST

Identified

Users may experience intermittent issues with the Carta application as our vendor Cloudflare is having global issues.
Posted Nov 18, 2025 - 06:25 PST
This incident affected: Application.