Login button on www.carta.com redirect
Incident Report for Carta System Status
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 17:59 PST
Identified
The login button on www.carta.com is redirecting to the wrong location. This can be bypassed by going to
https://login.app.carta.com/credentials/login/
Posted Feb 25, 2021 - 17:52 PST