Unable to exercise using Chrome 96
Incident Report for Carta System Status
Resolved
This incident has been resolved.
Posted Nov 18, 2021 - 20:16 PST
Investigating
We are currently investigating an issue with Chrome 96 that prevents users from exercising. As a workaround users are encouraged to use another browser such as Safari or Firefox.
Posted Nov 18, 2021 - 17:17 PST