User invitations
Incident Report for Carta System Status
Resolved
This incident has been resolved.
Posted May 25, 2022 - 14:33 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 25, 2022 - 11:35 PDT
Investigating
We are currently investigating an issue with the user invitations
Posted May 25, 2022 - 10:42 PDT